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Introduction

SplashID provides quick and easy access to all of your personal identification information, including 
usernames, passwords, credit cards, PINs, calling card numbers, frequent flyer numbers, insurance 
info and more. Data is stored in a secure, encrypted, password protected format.

Installation

After downloading the EXE file, double click to run it, and follow the prompts.

You may optionally install a Internet Explorer Plugin that will install a search box for SplashID Web 
Logins in your web browser bar. This is very handy for quickly logging into websites you have stored 
in SplashID. For more info on this feature, see the Internet Explorer Plugin section. 

SplashID will install the plugin for only one user - the active user in the SplashID desktop at the 
time of installation. If you need to change the user for which it is installed, you can do this at any 
time by reinstalling the plugin using the same method.

Activation

When you launch SplashID you will be prompted to activate. If you have purchased already, just 
enter the email address you used to purchase. You can activate on up to two machines before you 
will need to purchase additional licenses. If you have not yet purchased, you can do so without 
leaving the application. If you are a licensed owner of a previous version, enter your registration 
code to qualify for the reduced upgrade pricing.

Quick Start

1.  Launch SplashID and you will be asked to enter your email ID. This is used both for activation 
purposes as well as to uniquely identify your database with yourself.

2.  You will then be asked to set a password, and a hint. Make sure you can remember this 
password, because it cannot be removed or reset without deleting your data.

3.  Next, you will see the Panel View with several sample records will be displayed.
4.  Click New to create a new record or double click a sample record to edit it. In the Edit View 

select a Type, such as Credit Card or Web Login, and you will see the Field Labels change 
accordingly. 

5.  Click Done when you are finished entering the information for the new record and you are 
returned to the Panel View.

 

 

 

 

 



Application Features

When you launch SplashID you are presented with the Panel View, which displays a list of your 
items in a 3-panel layout. Items are records of information, like a credit card number and expiration 
date; or a username and password for a web-site. There are two other useful views, List View and 
Tree View, which you can select with the view buttons toward the top of the window.

Panel View

List View Tree View



SplashID Safe has some great features that defy categorization:

●     Pattern Login -- If you are a fan of this feature on the iPhone application, you can now use 
the same method to login to the desktop.

●     Smart Types -- The Panel View has a small mini-panel at the bottom left which displays 10 
of each of the following Smart Types: Most Viewed, Recently Modified, and Recently Viewed. 
These are similar to Smart Playlists in iTunes.

●     Customizable Toolbar -- SplashID uses a ribbon UI for the toolbar that MS Office users will 
be familiar with. We'll go over the tools in the next section - Toolbar Ribbon.

●     Sorting -- In the List View, click the column header to sort by that column. Click again to 
reverse sort. 

●     Reminder feature for individual records -- To use it, double click a record to edit, then 
click the Reminder button. Choose the date in the future you want to be reminded to update 
the record. Save. You'll get the reminder when you launch on that day. Great for passwords 
that you need to change regularly or credit cards expiration dates.

 

 

Toolbar Ribbon

SplashID Safe for Windows has an MS Office style Toolbar Ribbon. You will find many of the tools in 
the 4 tabs of the ribbon. 

Home Tab

●     New -- Click to add a new record, type or category.
●     Categories & Types -- Use the filters to restrict the list to only display items assigned to a 

specific Categories and Types.
●     Users -- Click the menu to select the User ID to work with. You can add additional users by 

clicking Edit Users. 
●     View Mode -- Use the View Mode buttons to select from the default Panel View, traditional 

List View, or hierarchical Tree View. 
●     Security -- Set a new password or lock the application.
●     Options -- Access the Options panel.
●     Search -- Enter some text you want to search for and results will display instantly.

 

 



Edit Tab

●     Clipboard -- Cut, copy and paste record(s) to/from the clipboard. For security, clear 
passwords from the clipboard with the (you guessed it) "Clear" button.

●     Copy Fields -- Select from the menu which field you wish to copy. Note: You may also type 
Ctrl-1 through Ctrl-9 to copy fields 1 through 9 to the clipboard. Alternatively, hover your 
mouse pointer over the field you wish to copy, then click the Copy button to copy that field to 
the clipboard.

Item Tab

●     Create -- Create a new record or duplicate the selected one.
●     Edit -- Edit the selected item, set Custom Field Labels, or Add an Attachment (any file up to 

1 MB) to the record for future reference. Attached files are saved in a folder next to the 
database.

●     Delete -- Delete the selected item or find duplicate records for deletion.
●     Action -- Use the Web Autofill feature, or email the selected record(s).

Others Tab

●     Database -- Reset SplashID is a great way to wipe your database off a system when you are 
moving on. Database sync can sync two or more SplashID Desktop databases with each 
other. Install to Removable Device will install a copy of SplashID on a removable device such 
as a USB thumb drive and a copy of your database. Then you will be able to take SplashID 
with you and run it from any remote computer. 

●     Plugin -- You have the option of installing a browser plugin (Internet Explorer only) that will 
add a search box to the address bar. With this you can quickly look up a Web Login from your 
SplashID database.

●     View -- View an activity log for tech support purposes. Enable/disable the Status Bar and 
Detail Pane.



Anything not found here will likely be found in the bottom toolbar or in the Application menu 
indicated by the SplashID icon in the top left. 

Application Menu

●     New -- Click to add a new record, type or category.
●     Edit -- Edit the selected item, set Custom Field Labels, 

or Add an Attachment (any file up to 1 MB) to the 
record for future reference. Attached files are saved in 
a folder next to the database.

●     Import -- Import SplashID vID files, CSV files, and 
other export formats from similar applications. 

●     Export -- Export SplashID vID files for various versions 
as well as CSV plain text files that can be used for a 
number of applications.

●     Backup -- Create a backup file of your database that 
can be restored at a later date.

●     Restore -- Restore a backup from vID, replacing the 
current data with the restored file.

●     Print -- Print the list of records.
●     Check for Update -- See if there is a newer version of 

SplashID available for download.
●     SplashID Feedback -- Send us feature requests, bug 

reports, etc. 
●     About -- Displays version information.
●     Options -- Customize the Quick Access toolbar as well 

as the style of the ribbon UI.
●     Exit -- Close the application.

 

 

 

 

 

 

 



 

Options

When you click the Options button or select Options from the SplashID menu, you will see the dialog 
above, with the following options:

Security 

●     Clear Clipboard -- Instruct SplashID to clear copied text from your system's clipboard either 
on exit or after a specified number of minutes.

●     Search Options -- Apply the search text to All Fields or Just Field 1.
●     Minimize Options -- Minimize to the Task Bar (like most applications) or to the System Tray 

(bottom right - more compact).
●     Auto-Submit Web Logins -- Check this box to automatically submit forms when using the 

Web Auto-fill feature.
●     Run SplashID on Startup -- Automatically start SplashID when you log into you system.
●     Play sound on Lock/Unlock -- Turns on or off the "click" sound you hear at login.
●     Clear Filters on Exit -- Resets the filter settings to the default when you quit the app.
●     Auto lock -- Set the period of inactivity that must pass before the application locks itself. For 

your security, the limit is 60 minutes.

Data/Backup 

●     Database Location -- Select a Custom database location, including network locations. Note: 
You cannot select a folder that already contains a SplashID database. See Database Sync if 
you wish to share data.

●     Default Backup Location -- Change the location that the automatic vID backup is saved to. 



●     Enable Auto Backup -- If enabled, a VID backup file of your database will be emailed to 
you. You can set how often this happens in the field below. The VID file can be imported in 
case of a catastrophic loss of data. Your SplashID password protects the file.

Format 

●     Font -- Select the Font type, style, size and color from the fonts on your system.
●     Row Color -- Select the color of the rows in List View, which will also be applied as the 

background color in the Panel and Tree Views. 

Show Columns -- Select which field data columns you would like to display in the List View. 

Sync - Edits the mobile device Synchronization settings.

 

Editing Records

Open the Edit dialog for a given record by double-clicking a record.

●     Type -- Select the Type from the Type menu. The Type will dictate the default field labels, 
icons, and masking preferences for the record. See more about Categories and Types.

●     Category -- In the top right of the Edit View screen, you can change the Category. It will 
default to the Category you were displaying when you created the record. See more about 
Categories and Types.

●     Fields -- Enter your data according to the field labels. 
●     Custom Field Labels -- You may assign Custom Field Labels by clicking the Custom button.
●     Masking -- A bullet appears to the right of any field that is masked. You may Customize the 



field masking by clicking the bullet or selecting Customize Field Labels from the Options .
●     Buttons -- 

❍     Icon: opens the icon selector. You can also add a custom icon to any record - just click 
Add Icons from the icon picker screen.

❍     OK exits the record, saving any changes. 
❍     Cancel exits the record, discarding any changes.
❍     Duplicate creates a copy of the record.
❍     Delete deletes the current record, after confirming that is what you wish to do.
❍     Custom opens the Custom Field Label dialog.
❍     Password opens the Automatic Password Generator.
❍     Autofill opens Internet Explorer to the record's URL, pastes in the username and 

password, and submits the form if Auto-Submit is turned on in Options.
❍     Print prints the record you are editing.
❍     Reminder allows you to set a reminder that will appear on launch on the selected date.
❍     Attachment Attach a file (1 MB or less) to the record for future reference by clicking 

the button next to the Attachment field. Attached files are saved in a folder next to the 
database.

 

 

 

 

Web Auto-Fill

For Web Logins, you can have SplashID launch Internet Explorer and automatically fill in the 
username and password fields for you. Please take note of the following:

●     Record type must be assigned to Web Logins.
●     Username and password fields should be filled in.
●     URL field must begin with either http://, https:// or www. Find the correct URL to get to the 

login screen on the selected website -- this is often not the homepage. For example, for 
Amazon.com, use https://www.amazon.com/gp/css/account/address/view.html.

●     This may not work with all sites. 

 

 

 

 

 



 

Internet Explorer Plugin

You have the option of installing a browser plugin (Internet Explorer only) that will add a search box 
to the address bar. With this you can quickly look up a Web Login from your SplashID database.

To install the plugin, run the SplashID desktop and select "SplashID Internet Explorer Plugin" from 
the File menu, and select Install. SplashID will install the plugin for only one user - the active user 
in the SplashID desktop at the time of installation. If you need to change the user for which it is 
installed, you can do this at any time by reinstalling the plugin using the same method. To uninstall 
the plugin, go to Application Menu > SplashID Internet Explorer Plugin > Uninstall.

Here is a breakdown on the plugin features:

●     Search Box -- Enter some text to search on, like Amazon, and SplashID will display 
matches. Click on a matching Web Login to open the URL and autofill the username and 
password. Click on a matching Other Record to view the details for copy and paste purposes.

●     Click the SplashID button to access menu options: 
❍     SplashData.com -- Opens our website so you can explore our software catalog.
❍     Web Logins -- Select one of your Web Logins from the list to en the URL and autofill 

the username and password.
❍     Other Record Types -- Use this to access other types of records, such as 

membership numbers and credit cards, so that you can copy and paste the numbers 
into a field on the page you are viewing.

❍     New Record -- Opens SplashID desktop with the Edit Dialog open for a new record.
❍     Security Options -- Set the timeout period for the browser plugin. When this period 

expires, you will be required to reenter your password to use the plugin.
❍     Auto-Submit Web Logins -- Click this to turn on the feature that will automatically 

submit forms when using the Web Auto-fill feature.

 



Database Sync

 

Note: This is a desktop to desktop sync solution. This is not the feature used to sync with mobile 
devices. For mobile device sync, see Synchronization.

You can synchronize multiple database files manually, at launch, and/or at exit. This is an advanced 
feature, not recommended for beginner users. As always, it is recommended that you backup your 
data with a vID export before trying out this feature, so you can revert if you lose anything. Please 
Note: You can only sync with other version 5 or later database files. 

To synchronize multiple database files:

1.  Click Add File and select a remote database to sync with. (Your database does not need to be 
selected).

2.  Select the Sync Mode 
❍     Synchronize -- Compares the databases and writes changes to each. 
❍     Current to Remote -- Overwrites remote data with current user data. 
❍     Remote to Current -- Overwrites current user data with remote data. 

3.  Set In Case of Conflict -- Current wins or Remote wins.
4.  Set Sync on Startup preference.
5.  Set Sync on Exit preference.
6.  Check the boxes for the databases you would like to sync.
7.  Select Sync Selected or Sync Now.

 

 

 

 

 

 

 



Automatic Password Generator

To open the Automatic 
Password Generator, click the 
Password button in the Edit 
Dialog.

To create a password:

1.  Set the Length and/or 
strength.

2.  Check or Uncheck the 
pronounceable setting. 

3.  Choose from the 
Character Sets one or 
more options of letters, 
numbers, symbols, or a 
combinatory thereof.

4.  Click Generate. click 
again until you get a 
suitable password.

5.  Click OK when you have 
decided.

Categories and Types

The difference between Categories and Types is best illustrated by example. You may use 
Categories to separate your Business records from your Personal records, while you use Types to 
separate your Credit Card records from your Web Login records.

Categories act as filters for grouping related records. The two pre-defined Categories are Business 
and Personal, though you may add more by choosing Edit Categories from the Category menu.

Types act as templates, which define the structure for the items you want to store in SplashID. You 
may define up to 9 custom field labels and a default icon for each type, as well as specify the fields 
you wish to mask. For example, you may create a type for Web Logins, which includes custom field 
labels for username, password and URL, with a globe icon, and the password field masked; and you 
may create a Type for Credit Cards which includes custom field labels for credit card number, 
expiration date and PIN, with a Visa icon, and the credit card number and PIN masked.

●     Edit Types -- Click the Edit Types button in the bottom left. You may create an unlimited 
number of Types. Several sample Types are provided, which you may edit or delete. Select 
an existing type and click edit, or click New to create a new one. The Define type dialog is 
displayed.

●     Define Type -- Enter a name for the Type and up to 9 custom field labels. The Mask 
checkbox specifies whether or not the data in that field will be masked. And you may also 
specify a default icon for the Type.

 



Custom Field Labels

Field Labels and masking are set by default when you define a Type. You may change the Field 
Labels and masking, however, at the record level by clicking the Custom button in the Edit Dialog. 

Masking

Fields that are Masked appear as four asterisks (****). You may show or hide the masked data by 
clicking the Mask toggle on the upper right corner of the screen. If you wish to permanently mask or 
unmask a field, you can change its mask setting in the Edit Type dialog or the Custom Field Labels 
dialog.

Find

You may search for records in SplashID by typing in the Find box (press Control-F to jump there). 
All fields in all records in SplashID will be searched and any matching records will appear in the 
results below. You may then click an item to go to the Detail View for that item. Select the contents 
of the Find box and press backspace to clear the Find. 

Security

You should secure your data in SplashID so that a password must be entered to access the 
application. You will be required to enter the password when launching SplashID. Once you set a 
password, SplashID encrypts your data using both AES and Blowfish encryption to ensure data 
security.

●     Setting a Password -- To set a password, select Set Password from the File Menu. The Set 
Password dialog is displayed. Enter a password in the New Password field, and verify the 
password by entering it again in the Confirm field. You may also choose to set the password 
as a pattern you can draw to login, just as on the iPhone version.

You will also be asked for a hint and a hint question. If you have trouble remember your 
SplashID master password, you can request the hint from the login dialog. Then you will be 
asked your hint question, and if you answer correctly, the hint will be displayed. 

●     Entering a Password -- You will be required to enter your password each time you launch 
SplashID. You may enter the password using the keyboard or the pattern login described 
below.

●     Changing a Password -- To change a password, select Set Password from the File Menu, 
enter your Old Password, then enter and confirm the New Password.



●     Removing a Password -- To remove a password, select Set Password from the File Menu, 
enter your Old Password, then leave the New Password and Confirm fields blank.

Pattern Login -- If you are a fan of this feature on the 
iPhone application, you can now use the same method 
to login to the desktop. Each dot represents the 
numbers 1 through 9. You can draw a pattern using 3 
or more of the dots in connection, with the only 
limitations being that the pattern cannot cross over 
itself or connect dots not immediately adjacent. You 
can draw diagonally, for example, but only to the 
nearest diagonal neighbor.

Auto-Lock -- Check Choose Auto-Lock in the Preferences > Security dialog to specify the period of 
inactivity that must elapse before SplashID auto-locks. Once SplashID locks, you must enter your 
password to open SplashID. 

Reset SplashID -- In the File menu, you will find a tool that helps you to erase data and 
preferences for SplashID. This is useful, for example, when you are leaving a computer behind and 
want to remove your SplashID information completely. In the reset process, you will have the 
option of securely or archiving data, and you can reset just one user or all users on the system. If 
you opt to securely erase, make sure you have your data somewhere safe, such as on a new 
computer or on your handheld device to be transferred to a new computer when you get there.

 

 

 

 

 

 

 

 



Synchronization

Items may be created or edited on the Handheld or Desktop and the changes can be synchronized 
over your local Wi-Fi network. By default information is synchronized in both directions, but you can 
adjust the settings, in Sync settings which can be found in the Options dialog.

In most cases, you will wish to leave the Default setting (on the right) set to Synchronize. This 
means that after changing it to Desktop Overwrites Handheld and doing a sync, it will revert back to 
Synchronize for the next sync so you don't have to go back in and change the setting back manually.

Here are the possible sync settings and the results they will bring about: 

●     Synchronize -- Changes made on the Handheld or the Desktop will be synchronized. If a 
record is edited on both sides between syncs, the latest edit will win.

●     Desktop overwrites handheld -- All data on the Desktop is copied to the handheld. Any 
data on the Handheld will be replaced.

●     Handheld overwrites Desktop -- All data on the Handheld is copied to the Desktop. Any 
data on the Desktop will be replaced.

In order to synchronize, you must do the following:

1.  Have your handheld and desktop computer join the same network
2.  Open the SplashID desktop and Select the correct user from the User menu
3.  Set the passwords the same on both the desktop and handheld software
4.  Adjust the Sync settings in Options if you wish 
5.  Start the Sync on the handheld

 

 

 



SplashID Global IP Address Synchronization

You can sync with your PC even if you don't have Wi-Fi. It is more difficult, however, because it 
requires making your computer's IP address globally reachable from your iOS device. Here is a 
general guide.

You need to reach your PC via the internet connection on your iOS device. This means you 
need your global IP address. This may be different from your IP address if there is a wireless router 
between you and the internet. The global IP address is the address of the Cable or DSL modem on 
the internet - essentially the internet address of your home. 

Determine your global IP address by going to: http://whatismyip.com

If your PC is connected directly to your Cable/DSL modem, ie. connected "Directly" to the 
internet, then it probably already has a global IP address. To determine if your Mac has a different 
"local" IP address, go to System Preferences > Network, and see if it matches http://whatismyip.
com

If your PC is connected (by ethernet or Wi-Fi) to a wireless router, then you would need to 
forward your SplashID port to the local IP address. You will find configuration instructions here: 
http://portforward.com - this portal pretty much covers all the Wireless Router and Modems.

The port you need to forward is 6674.

You want to forward the public port 6674 to the private port 6674 of the IP address assigned to 
your PC.

Sync to your computer's IP address from SplashID on the iOS device

Once you have updated the wireless router's settings to forward this port to your PC, you can now 
sync with the SplashID desktop:

1.  Tap the sync button in SplashID on the device
2.  Select Enter SplashID Desktop IP Address To sync with >
3.  Put the global IP address into the field, then Tap Done
4.  Start Sync

Again, you can obtain this IP address from http://whatismyip.com
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Import/Export

You can share information with other SplashID Safe users by exporting and importing your SplashID 
records. Records can be exported/imported on the desktop in several formats:

SplashID vID
You may import and export SplashID records in SplashID Virtual ID (vID) format, which allows you 
to export and import records in a secure, encrypted format. vID files may be encrypted by assigning 
a password when exporting. The recipient of the vID file may import the data into their copy of 
SplashID Safe by double-clicking the file, or choosing Import/SplashID vID from the File Menu. If a 
password was assigned to the file, the recipient must enter the password in order to import the data.

You have the option of exporting a version 5, version 4, or version 3 vID file. This helps with 
backwards compatibility. Since version 5 or later databases may contain attached files, these will 
not be supported by version 4. 

To export a version 5 vID file (for use in SplashID 5 or 6), go to Application Menu > Export > 
SplashID vID. You may also export by right-clicking a record in the list and selecting Export.

To export a version 4 vID file, go to Application Menu > Export > SplashID vID, but uncheck the 
Export Attachments checkbox in the export dialog.

To export a version 3 vID file, go to Application Menu > Export > SplashID vID3. This only exports 
fields 1 thru 6 and the Notes, so it can be imported into SplashID 3.

vID files are a convenient way to share records with a coworker or spouse by exporting a vID file, 
assigning a password (optional), and then emailing the resulting vID file to the recipient. You can 
even use the vID format as a backup mechanism by periodically exporting a vID file and archiving it 
on a backup disk.

You can also use the Email button on the SplashID desktop to export vID files and attach them to a 
new email message. 

CSV
You may also import and export SplashID records in CSV format. CSV stands for Comma Separated 
Values, and is a common file format readable by most spreadsheets, databases and word 
processors. If you wish to import a CSV file, the data must be in the following format:

Type,Field 1,Field 2,Field 3,Field 4,Field 5,Field 6,Field 7,Field 8,Field 9,Date Modified: "Month DD,
YYYY",Notes,Category

It is easy to create the above format in Excel by creating a spreadsheet with 13 columns (as 
designated above) with one record per row. Then save the file in CSV format.

Note: When importing data, if the type field is blank the record will be placed in Unfiled. If there is a 
type name and it does not match an existing type a new type will be created.

 

 

 



Backup and Restore

Automatic vID Backups
SplashID Safe has an automatic backup feature which will allow you to easily recover data in most 
cases. Whenever the data has been changed, a backup is made each time you exit SplashID Safe. A 
vID export file is created (and encrypted with the same password you are using in SplashID) and 
stored in:

c:\Users\<username>\Documents\SplashData\SplashID\Backup\<userID>

Up to 10 backups will be saved incrementally. You can see which is most recent by the file date. 
When 10 backups have been saved, SplashID will start saving from backup 0.vid again. This is 
helpful in cases where you had data loss and then exited the application. The most recent backup 
may be empty, but the previous backups are likely to contain your data.

If you later need to restore this data, simply double-click the .vid file and you will be prompted for a 
password and the data will be imported into SplashID Safe.

You may change the location that this file is backed up to in SplashID Options. 

Automatic Email vID Backups
There is also an option in Options to have a backup VID file emailed to you on a specified schedule 
(every day by default) so that you can potentially store this on an email server in case of 
catastrophic data loss such as a failed hard drive.

Manual vID Backups
You may also perform a manual backup of your data by selecting Backup from the File menu. This 
will export your SplashID Database in vID format to whatever location you select. You will be given 
the option to set a password as well, which will encrypt the data and require the password to 
restore it.



 

Restore
Select Restore from the File menu to restore a vID file that has been backed up either automatically 
or manually as described above. The password will remain the same for the application even if the 
password for the backup file was different.

Desktop
The SplashID Safe database file is automatically saved to the SplashID directory on your hard drive 
each time you exit the application. You may back up this file as an added precaution in case of a 
hard drive failure. To restore the backup file simply copy it into the SplashID directory. Then the 
next time you launch SplashID it will open the file. This file is stored here: 

c:\Users\<username>\Documents\SplashData\SplashID\<userID>\SplashID Database.sdb 

You may change the location that this file is saved to in SplashID Options.


